Agents

Requirements

Operating systems
  • Windows 7 in 32 and 64 bits. Updates KB2533623, KB2922790, KB3147071 KB4474419 and KB4490628 are necessary. The update KB3191566 is required in order to use the protection against WMI Persistence.
    Ensure that the Windows firewall service is running, otherwise the installation of the agent will fail.
  • Windows 8.1 update 3 (August 2014) - 32 or 64 bits
  • Windows 10 Enterprise 2015 LTSB - 32 and 64 bits

  • Windows 10 Enterprise 2016 LTSB - 32 and 64 bits

  • Windows 10 Enterprise 2019 LTSC - 32 and 64 bits

  • Windows 10 20H2 – 32 and 64 bits

  • Windows 10 21H1 – 32 and 64 bits

  • Windows 10 21H2 – 32 and 64 bits

  • Windows 11 21H2 – 64 bits

  • Windows Server 2008 R2. Update KB2533623 is necessary. The update KB3191566 is required in order to use the protection against WMI Persistence.
  • Windows Server 2012 R2*
  • Windows Server 2016*
  • Windows Server 2019*
  • Windows Server 2022*

*Including the Server Core version.

Processors for physical machines
  • 32-bit processors: at least Intel Pentium 4 2 GHz or the equivalent,
  • 64-bit processors: at least Intel Pentium 4 2 GHz with x86-64 support or the equivalent.

Itanium processors are not supported.

Processors for virtual machines

At least one virtual socket and a single 1 GHz core per socket. Stormshield recommends one virtual socket and two 2 GHz cores per socket.

CPU reservation must be enabled on your hypervisor.

Physical memory At least 1 GB. Or more if the operating system requires it. Stormshield recommends 2 GB.
Disk space
  • At least 100 MB for installation,
  • At least 200 MB for data storage.

These are the disk space requirements for the NTFS file system. More space will be needed for updates and log storage.

Network configuration
  • Outgoing communication:
    • TCP 17000 (RPC)
Software Framework .NET 4.6.2 or higher.
Display At least 1024X768.
Certificate
  • VeriSign Universal Root Certification Authority certificate installed to verify the authenticity of SES Evolution updates.
    It must be installed in the Trusted root certification authorities or Third-party root certificate authorities certificate store.