Compatibility

Lowest version required

Intermediate updates may be necessary to upgrade firewalls in version 4.2.4.

  • From a 2.X version: simply update the firewall beforehand to version 3.7.16 LTSB, then version 3.7.18 LTSB,
  • From a 3.X version: simply update the firewall beforehand to version 3.7.18 LTSB, then version 3.11.6 LTSB,
  • From a 4.X version: simply update the firewall beforehand to version 4.1.1 or 4.1.2.

Hardware compatibility

SN160(W), SN210(W), SN310, SN510, SN710, SN910, SN1100, SN2000, SN2100, SN3000, SN3100, SN6000 and SN6100
SNi20 and SNi40
Stormshield Network Elastic Virtual Appliances: EVA1, EVA2, EVA3, EVA4, EVAU and VPAYG

Hypervisors

VMware ESXi Versions 6.5 and 6.7
Citrix Xen Server Version 7.6
Linux KVM Red Hat Enterprise Linux 7.4
Microsoft Hyper-V Windows Server 2012 R2 and 2019

Authentication - Microsoft servers

RADIUS
Kerberos
Microsoft Active Directory - LDAP(S)
Windows Server 2012 R2 and 2019
SPNEGO Windows Server 2012 R2, 2016 and 2019

StormshieldNetwork client software

Windows SSO Agent Version 3.0.1
Linux SSO Agent Version 3.0.1
SSL VPN client Version 2.9.1
IPSec VPN Client Version 6.64.003

SN Real-Time Monitor

SN Real-Time Monitor version 4.0.0 is not compatible with firewalls in version 4.2.1, 4.2.2 and 4.2.4. A specific version of SN Real-Time Monitor compatible with SNS firewalls in version 4.2 will be released later.

Web browsers

In order for the firewall administration interface to operate optimally, you are advised to use the latest versions of Microsoft Edge, Google Chrome and Mozilla Firefox (ESR version - Extended Support Release). For further information on these versions, please refer to the relevant vendors for the life cycles of their products.