Pré-requis

Pour faire fonctionner le SSO (SPNEGO) avec les Firewalls SNS, les outils suivants sont nécessaires :

  • Un Firewall Stormshield en version 3 ou supérieure,
  • Un serveur Windows avec Active Directory activé et configuré. Les versions Microsoft Windows Server compatibles sont les suivantes :
    • Windows Server 2008 et 2008 R2,
    • Windows Server 2012 et 2012 R2,
    • Windows Server 2016.
  • Le script spnego.bat v1.6 disponible dans votre Espace Client. Ce script requiert la présence des outils système suivants sur le serveur :

    • Reg.exe pour manipuler la base de registre du serveur,
    • Setspn.exe pour définir le nom de service dans l’annuaire Active Directory,
    • Ktpass.exe pour récupérer la clé de chiffrement (keytab),
    • Ldifde.exe pour interroger la base LDAP.

NOTE

  • Des postes de travail connectés sur le domaine Active Directory, pourvus d’un navigateur compatible avec SPNEGO. Pour un fonctionnement optimal de SPNEGO, il est recommandé d'utiliser la dernière version des navigateurs Microsoft Internet Explorer, Microsoft Edge, Google Chrome et Mozilla Firefox (version ESR - Extended Support Release). Pour de plus amples renseignements sur ces versions, nous vous invitons à consulter le Cycle de Vie des Produits des éditeurs concernés.
  •